aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDemonKingSwarn <rockingswarn@gmail.com>2024-02-01 01:27:59 +0530
committerDemonKingSwarn <rockingswarn@gmail.com>2024-02-01 01:27:59 +0530
commitec911e39b920dddf42be1c6622c0a22b711de238 (patch)
treef42b80181163592ec87003738e76e6b0098419d8 /pyproject.toml
parentd52dbe5006b12ddfef8317ff472cc8120799687c (diff)
downloadyt-music-ec911e39b920dddf42be1c6622c0a22b711de238.zip
yt-music-ec911e39b920dddf42be1c6622c0a22b711de238.tar.gz
chore: migrated to pyproject
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..8218a02
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,21 @@
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"
+
+[tool.poetry]
+name = "yt-music"
+version = "0.0.1"
+description = "A command line YouTube Music client."
+authors = ["DemonKingSwarn <rockingswarn@gmail.com>"]
+license = "GPLv3"
+readme = "readme.txt"
+
+[tool.poetry.dependencies]
+python = "^3.10"
+httpx = "0.23.0"
+krfzf-py = "^0.0.4"
+
+[tool.poetry.dev-dependencies]
+
+[tool.poetry.scripts]
+yt-music = "yt_music.__main__:__ytmusic__"